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Abstract: This article explores the integration of Artificial Intelligence (AI) into 

Microsoft Excel through tools such as ChatGPT, Numerous AI, and GPT for Excel. 

By leveraging natural language processing and machine learning, users can enhance 

productivity and automate tasks that traditionally require manual input or advanced 

formula knowledge. The paper presents categorized examples of AI-powered 

functions, including content generation, grammar correction, sentiment analysis, data 

translation, and formula assistance. Designed for both beginner and advanced users, 

this guide demonstrates how AI can transform Excel into a smarter, more intuitive 

tool for data management, reporting, and everyday tasks. 
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1. Introduction  

Artificial Intelligence has become a powerful tool across industries, and Microsoft 

Excel is no exception. With AI integrations such as ChatGPT, Numerous AI, or 

GPT for Excel, users can now automate complex tasks, generate content, analyze 

text, and build smart tables directly within cells — no advanced formulas or coding 

required. 

From creating fictional student databases and translating text instantly, to detecting 

sentiment, summarizing content, or rewriting text professionally, AI brings new 

capabilities to everyday spreadsheets. 

In this paper, we’ll explore some of the most practical and powerful AI functions 

in Excel, grouped by category, complete with real examples to help we unlock 

the full potential of intelligent automation in the workflow. 

 

2. State of the Art 

Artificial Intelligence (AI) is increasingly integrated into Microsoft Excel, 

revolutionizing how users analyze and manage data. Microsoft's 365 Copilot uses 

large language models to enable natural language interaction, allowing users to 

generate formulas, summaries, and visualizations without deep Excel expertise 

(Microsoft 2023). This AI-powered assistant simplifies complex tasks, making 

Excel more accessible. 

Researchers have explored augmenting Excel’s automation with AI-enhanced 

VBA scripting, which improves decision-making and workflow automation 
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(Thiruvenkadam 2023). Additionally, third-party tools like Numerous AI provide 

AI-driven formula generation and data interpretation via natural language 

prompts, reducing technical barriers (Numerous.ai 2024). 

On the academic front, Microsoft’s SpreadsheetLLM helps extract insights from 

complex spreadsheets, boosting enterprise productivity (Davis et al. 2024). The 

InstructExcel benchmark evaluates AI models’ ability to convert natural 

language instructions into Excel commands (Payan et al., 2023). Meanwhile, 

ExceLint applies machine learning to detect and fix formula errors automatically 

(Barowy et al., 2019). 

Together, these advances highlight AI’s growing role in transforming Excel from 

a manual tool into an intelligent assistant that enhances accuracy and efficiency. 

 

3. What Is ChatGPT for Excel? 

Microsoft Excel does not have native ChatGPT integration, but there are third-

party add-ins that allow to use ChatGPT's capabilities directly within Excel. These 

extensions can transform how the work with data, formulas, and text.  

Essentially, ChatGPT for Excel refers to tools that integrate OpenAI’s language 

model into Excel, enabling we to use natural language to perform various tasks—

such as generating formulas, explaining existing ones, auto-completing cells, 

summarizing or translating text, and even performing content analysis like 

sentiment detection or automatic classification. 

There are several ways to use ChatGPT in Excel. One popular option is the “GPT 

for Sheets and Docs” add-in (originally for Google Sheets, but also functional in 

Excel via the web), developed by Talarian. It allows users to write formulas like 

=GPT("Write a formula to calculate 19% VAT"), and it requires an OpenAI 

API key, which usually comes with a cost.  

Another widely used tool is ChatGPT in Excel by Numerous AI, a more visual and 

user-friendly add-in that lets we select cells and generate or rewrite content using 

predefined functions such as =AI(), =SUMMARIZE(), or =TRANSLATE(). This is 

especially helpful for non-programmers. 

For advanced users, it’s also possible to connect Excel directly to the OpenAI API 

using Power Query or VBA. This setup allows to send data from cells to ChatGPT 

and receive responses—like summaries or suggestions—directly into the 

spreadsheet. 

In practice, ChatGPT in Excel can help with a wide variety of tasks. If we don’t 

know the right formula, we can simply write a plain-language request like 

=GPT("calculate the average without zeros") and get the correct formula. 

We can summarize long texts in a cell using =SUMMARIZE(A1), translate text with 

=TRANSLATE(A1, "ro", "en"), analyze reviews or comments for sentiment, and 

even fill in missing data or reorganize tables based on suggestions. 

These tools are developed by third parties, not Microsoft. While some features are 

free, others may require a subscription or paid API access. Also, since the data may 

be transmitted to external servers, it's important to avoid sending sensitive 

information unless it has the proper permissions. 
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4. Excel functions with AI integrated 

We can create a short list of Excel functions and categorize them according to their 

intended use. This feature is an application where the URL AI add-in is equipped 

with AI features, ChatGPT for Excel, and personalization integration with the 

OpenAI API. 

 

1. Content Generation (Text, Ideas, Tables) 

Function Example Usage 

=AI("...") =AI("Create a list of 5 fictional students with majors") 

=GENERATE(...) =GENERATE("Business slogan for a bakery") 

=EXPAND(A2) Expands or elaborates on a sentence or idea in cell A2 

 

2. Rewriting and Grammar Correction 

Function Description 

=REWRITE(A2) Rewrites the text in A2 for clarity or professionalism 

=CORRECT(A2) Fixes grammar and spelling mistakes in the text 

=SIMPLIFY(A2) Simplifies technical or complex language 

=FORMALIZE(A2) Converts casual language to a formal tone 

  

3. Text Analysis (Sentiment, Classification, Summary) 

Function Description 

=SUMMARIZE(A2) Summarizes long text in A2 

=CLASSIFY(A2) Classifies text by topic, intent, or category 

=DETECT_SENTIMENT(A2) Returns the sentiment: Positive, Neutral, or Negative 

=KEYWORDS(A2) Extracts keywords from the text 

  

4. Language and Translation 

Function Description 

=TRANSLATE(A2, "ro", "en") Translates from Romanian to English 

=DETECT_LANGUAGE(A2) Detects the language of the text 

=TRANSLATE_AUTO(A2, "en") Automatically translates to English 

  

5. Working with Formulas and Data 

Function Example and despription 

=AI("Write an Excel formula 

to...") 

=AI ("Write an Excel formula to calculate 

VAT at 19%") 

=EXPLAIN_FORMULA(A2) Explains what the formula in A2 does 
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Function Example and despription 

=CLEAN_DATA(A2) Cleans or normalizes inconsistent data 

=FILL_MISSING (A1:A10) Suggests on how to fill in missing values 

  

6. Education and Student Examples 

Function Description 

=AI ("Generate 5 quiz questions on 

biology") 

Creates practice questions or 

quizzes 

=AI ("Explain photosynthesis in simple 

terms") Simplifies academic concepts 

=AI ("Generate a student table with 

name, group, major") 
Generates demo student tables 

  

7. Advanced / Custom AI Functions (API-based or LAMBDA) 

Function Description 

=GPT_PROMPT (prompt, 

...) 

Sends a custom prompt to OpenAI and returns the 

result 

=LAMBDA_GPT(...) 
Custom Excel LAMBDA functions powered by 

GPT 

  

5. Case Study: Some examples of using AI with Micosoft Excel 

 

The first step are described, in order to use AI in Excel is the install ChatGPT 

(Numerous AI). 

  1. Open Excel (Microsoft 365 version recommended). Add-ins work best in 

the web version of Excel or the latest desktop version. 

  2. Go to Insert > Get Add-ins 

  3. Search for "Numerous AI" or "GPT" 

• Find the add-in called “Numerous AI” or “GPT for Excel & Sheets” 

• Click Add to install it. 
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Figure 1. How to install AI for Excel 

 

ChatGPT add-ins for Excel can help perform a variety of tasks using natural 

language. For example, if we don’t know how to write a specific formula, we can 

simply describe what we need, and ChatGPT will generate = GPT("calculate the 

average excluding zeros").  

If we have a long block of text in a cell, we can summarize it instantly with 

=SUMMARIZE(A1). Need to translate text automatically? Use a function like 

=TRANSLATE(A1, "ro", "en") to convert content from Romanian to English. 

When working with product reviews or user comments, the tool can perform 

sentiment analysis to identify whether feedback is positive or negative. ChatGPT 
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can also suggest missing data entries or corrections, and assist with table 

organization by recommending how to structure or analyze data more effectively. 

 

Example1: The AI.TABLE creates a table with a specific dataset using AI's 

capabilities. Just provide a prompt and optionally include a header, source data, 

creativity level, and the desired AI model. 
=AI.TABLE("Generate a table with 10 fictional university students. 

Include columns: First Name, Last Name, Group, and Major.") 

 

 

 

 
 

Figure 1. An example of using AI.Table 

Example2: The build of a tabel that contains Top 10 movies of all times, with 

release year and main actor. 
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Figure 2. Another example of using AI.Table 

 

Example 3: The AI. FORMAT function converts a text to a specified format. 

Provide the text range and the desired format range. This function standardizes 

and structures the data efficiently. 
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Figure 3. An example of AI.Format function 

Example 4. The AI.TRANSLATE function helps translate the content into multiple 

languages directly from the workbook. Simply provide the text, target language, 

and any optional instructions. 
 

=AI.TRANSLATE("Also since wer datawe may be transmitted to external 

servers, it's important to avoid sending sensitive information 

unless we have proper permissions", "German") 

 

Figure 4. An example of AI.Translate function 

Example 5. AI.LIST generate list outputs in separate rows to keep your thoughts 

organized. 
=AI.LIST("give me 5 email subject ideas for a workshop 

in Informatics") 

 
Figure 5. An example of AI.List function 

Example 6. The AI.FILL function fills an incomplete range by analyzing a 

provided example range to understand the pattern. Specify the example range 
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with complete data, the partial range to be filled, and optionally, adjust the 

creativity level. 
=AI.FILL(Q21:R23,Q24:Q28) 

=AI.FILL(G10:H12,G13:G23) 

 

 

Figure 6. An example of AI.FILL function 

6. Built-in AI Features in Excel (Microsoft 365 / Excel Online) 

Artificial Intelligence is becoming an integral part of office tools, and Microsoft 

Excel already includes smart features that make it easier to analyze data, visualize 

patterns, and support decision-making—even without programming skills. Here's 

how we can benefit from AI directly within Excel. 

Linked Data Types (Smart Data Categories) 

Excel can recognize certain words, such as “France” or “Apple,” as entities like a 

country or a company. Once recognized, we can extract structured data such as 

population, GDP, stock price, CEO, etc. To use this feature, we have to type a word 

into a cell (e.g., "Apple"), then go to the Data tab, choose Data Type, and select 

Automatic or a specific type (like Company or Geography). Excel will link the 

word to a data entity, allowing us to pull structured fields related to it. 

Analyze Data (formerly called "Ideas") 

This feature helps explore the dataset quickly by suggesting relevant charts, 

detecting trends, and highlighting outliers. To activate we select the data table, then 

click Home > Analyze Data. Excel will automatically present insights and visual 

suggestions based on the dataset’s structure and content. 
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Automatic Forecasting (Forecast Sheet) 

For time series data like monthly sales, Excel’s Forecast Sheet generates 

predictions and trend graphs. 

How it works: we select two columns (a time-based one and a value-based one), 

then go to Data > Forecast Sheet. Excel will generate a visual projection of future 

values based on historical patterns. 

 

Power Query + Cloud AI Integration 

Advanced users can connect Excel to cloud-based AI services, such as Azure 

Machine Learning. For example, we can train a predictive model in Azure and 

import its results directly into Excel using Power Query. 

 

AI for Charting and Visual Patterns 

While charts themselves aren’t driven by AI, Excel uses AI to suggest the most 

appropriate visualizations: 

The Analyze Data tool helps choose the best chart for the data. Quick Analysis 

(appears when we select a data range) offers a set of chart suggestions and pattern 

highlights. AI helps detect anomalies or recurring trends directly in visual 

outputs. 

 

AI Functions via Add-ins (ChatGPT and others) 

We can enhance Excel with AI-powered add-ins available from the Office Store, 

such as ChatGPT for Excel, DataSquirrel, or Numerous AI. These tools allow 

Formula generation from natural language, text data analysis and classification and 

smart content summarization or correction. 

Practical Use Cases 

Scenario AI Solution in Excel 

We have a product list and want to know top 

sellers 

Use Analyze Data to identify 

trends 

We need to forecast next month's sales Create a Forecast Sheet 

We want to quickly build visualizations 
Use Quick Analysis or Analyze 

Data 

We need details about companies or 

countries 
Use Linked Data Types 

We’re working with a large table and want 

insights 

Let Analyze Data suggest key 

findings 

Excel's integration of AI continues to grow, offering both everyday users and 

professionals intelligent tools to explore, understand, and act on data—without the 

need for complex formulas or code. 

Conclusion 

 

The integration of Artificial Intelligence into Microsoft Excel marks a significant 

evolution in how users interact with data. From built-in tools like Linked Data 
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Types, Analyze Data, and Forecast Sheet, to more advanced capabilities powered 

by add-ins such as ChatGPT or Numerous AI, Excel now offers powerful features 

that go far beyond traditional spreadsheet functions. These AI enhancements 

enable users to generate formulas from plain language, analyze trends and 

sentiment, visualize data intelligently, and even connect to cloud-based machine 

learning models—all without needing programming knowledge. As AI continues 

to develop, its role in tools like Excel will only become more central, helping users 

make faster, smarter, and more data-driven decisions across all fields. 
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